$re = '/^([^\nf].{2}|.[^\no].|.{2}[^\no])|^.{0,2}$/m';
$str = 'foo text
1oo text
f1o text
fo1 text
1
12
123
More text
12345 text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);