package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([^\nf].{2}|.[^\no].|.{2}[^\no]).*|.{0,2})$`)
var str = `foo text
1oo text
f1o text
fo1 text
1
12
123
More text
12345 text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}