$re = '/(cat)|[^c]*(?:c(?!at)[^c]*)*/s';
$str = 'I see a cat in the tree.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);