$re = '/^(?!foo)/m';
$str = 'foo text
1oo text
f1o text
fo1 text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);