package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-z]+`)
var str = `foo text
1oo text
f1o text
fo1 text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}