import re
regex = re.compile(r"^.*?:[ \t]+(\w+)", flags=re.MULTILINE)
test_str = (" In respect of Shareholders\n\n"
"Name: xyx\n\n"
"Residential address: dublin\n\n"
"No of Shares: 2\n\n"
"Name: abc\n\n"
"Residential address: canada\n\n"
"No of Shares: 2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")