# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>(?>([a-f0-9]{1,4})(?>:(?1)){7}|(?!(?:.*[a-f0-9](?>:|$)){8,})((?1)(?>:(?1)){0,6})?::(?2)?)|(?>(?>(?1)(?>:(?1)){5}:|(?!(?:.*[a-f0-9]:){6,})(?3)?::(?>((?1)(?>:(?1)){0,4}):)?)?(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]?[0-9])(?>\.(?4)){3}))$"
test_str = ("/*These should be valid*/\n\n"
"{Initial address}\n"
"2001:0db8:0000:0000:0000:ff00:0042:8329\n\n"
"{After removing all leading zeroes}\n"
"2001:db8:0:0:0:ff00:42:8329\n\n"
"{After omitting consecutive sections of zeroes}\n"
"2001:db8::ff00:42:8329\n\n"
"{The loopback address}\n"
"0000:0000:0000:0000:0000:0000:0000:0001\n\n"
"{The loopback address be abbreviated to ::1 by using both rules}\n"
"::1\n\n"
"{4 other valid test cases}\n"
"::FFFF:129.144.52.38\n"
"::129.144.52.38\n"
"::FFFF:d\n"
"1080:0:0:0:8:800:200C:417A\n\n"
"/*These 4 should be invalid*/\n"
"::FFFF:d.d.d\n"
"::FFFF:d.d\n"
"::d.d.d\n"
"::d.d")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.