re = /"(\w+)":{"id":"\1"/m
str = '..."StringToMatch":{"id":"StringToMatch","This":"SomeRandomThing"...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end