re = /^$|(?<!\bgoogle)bot|crawl|spider/m
str = 'googlebot
bot
this is a crawl
a crawler
certain bots'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end