package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*\..).(.\d++)\):(\s+error.*)`)
var str = `..\main.c(81): error: #20: identifier "s" is undefined`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}