re = /\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[1-2]\d|3[0-1])T(?:[0-1]\d|2[0-3]):[0-5]\d:[0-5]\dZ/
str = '2016-07-08T12:30:00Z'
# Print the match result
str.match(re) do |match|
puts match.to_s
end