import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Activate-Status(?!.*Ready)|Overall.*Status(?!.*Operable)|Operability(?!.*Operable)|Controller.*Status(?!.*Optimal)|Errors(?!.*0)|Dropped(?!.*0)|Discarded(?!.*0)|Bad(?!.*220)|Suspect(?!.*No)|Thresholded(?!.*0)|Visibility.(?!.*yes)|Thermal.*Status(?!.*OK)|HA.*(?!.*READY)";
final String string = "ID 20:\n"
+ " Location: G1\n"
+ " Presence: Equipped\n"
+ " Overall Status: Operable\n"
+ " Operability: Degraded\n"
+ " Visibility: foobar\n"
+ " Product Name: 16GB DDR3-1600-MHz RDIMM/PC3-12800/dual rank/1.35V\n"
+ " PID: \n"
+ " VID: V01\n"
+ " Vendor: 0x2C00\n"
+ " Vendor Description: Micron Technology, Inc.\n"
+ " Vendor Part Number: \n"
+ " Vendor Serial (SN): \n"
+ " HW Revision: 0\n"
+ " Form Factor: DIMM\n"
+ " Type: DDR3\n"
+ " Thermal Status: FUBAR\n"
+ " Capacity (MB): 16384\n"
+ " Clock: 1600\n"
+ " Latency: 0.600000\n"
+ " Width: 64\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}