$re = '/[0-9]+-(?\'slug\'[a-z-]+)/';
$str = '1115-poncho-carlo.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);