$re = '/<[a-zA-Z]+.*?>/s';
$str = '<a href="http:foo"<a href="http:foo">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);