$re = '/(?<=>)[A-Z0-9]{4,}(?=<)/m';
$str = '>00324R< >E223143< >00000F<';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);