re = /\$\{(?!pageContext\.).*?\}/
str = '${requestScope.user}
${sessionScope.user}
should match
but ${pageContext.request} '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end