package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([a-z\d]+),*\s*([a-z\d]+)*\)`)
var str = `'_(foo, bar)'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}