import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(interface [a-zA-Z0-9 <>,\\.\\/*?[\\s]]* \\{|(@Immutable|@ThreadSafe|@NotThreadSafe)(.*[\\n])*.*(class|enum) [a-zA-Z0-9\\s<>,\\.\\/*?]* \\{)";
final String string = "package de.invesdwin.common.persistence.jpa.api.dao;\n\n"
+ "import java.io.Serializable;\n"
+ "import java.lang.reflect.Field;\n"
+ "import java.util.ArrayList;\n"
+ "import java.util.List;\n\n"
+ "import javax.annotation.concurrent.ThreadSafe;\n"
+ "import javax.persistence.ElementCollection;\n"
+ "import javax.persistence.Embedded;\n"
+ "import javax.persistence.Query;\n"
+ "import javax.persistence.TypedQuery;\n\n"
+ "import org.apache.commons.lang3.mutable.MutableBoolean;\n"
+ "import org.springframework.data.domain.Page;\n"
+ "import org.springframework.data.domain.Pageable;\n"
+ "import org.springframework.data.domain.Sort;\n"
+ "import org.springframework.data.jpa.repository.support.SimpleJpaRepository;\n"
+ "import org.springframework.transaction.annotation.Transactional;\n"
+ "import org.springframework.util.ReflectionUtils.FieldCallback;\n\n"
+ "import de.invesdwin.common.lang.Assertions;\n"
+ "import de.invesdwin.common.lang.Reflections;\n"
+ "import de.invesdwin.common.persistence.jpa.PersistenceProperties;\n"
+ "import de.invesdwin.common.persistence.jpa.api.query.QueryConfig;\n\n"
+ "/**\n"
+ " * A DAO (DataAccessObject) is a special Repository that works for only one Entity. It implements default\n"
+ " * CRUD-Operations for it.\n"
+ " * \n"
+ " * JPA Entity attached/detaches status is automatically handled, so you don't need to care about that.\n"
+ " * \n"
+ " * @author subes\n"
+ " */\n"
+ "@ThreadSafe\n"
+ "public abstract class ACustomIdDao<E, PK extends Serializable> extends ARepository implements IDao<E, PK> {\n\n"
+ " private final Class<E> genericType;\n"
+ " private final boolean deleteInBatchSupported;\n"
+ " private final QueryByExampleHelper<E, PK> queryByExampleHelper;\n"
+ " private Integer connectionBatchSize;\n"
+ " private SimpleJpaRepository<E, PK> delegate;\n"
+ " private String persistenceUnitName;\n\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}