import re
regex = re.compile(r"(^\s+|\s+$)", flags=re.MULTILINE)
test_str = (" d sfdsfs \n"
" sd sdf ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)