re = /^\s*(?:\+?(\d{1,3}))?[-. (]*(\d{3})[-. )]*(\d{3})[-. ]*(\d{4})(?: *x(\d+))?\s*$/
str = '+989163678024'
# Print the match result
str.match(re) do |match|
puts match.to_s
end