package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([+]\s*7)|8`)
var str = `+ 7
8
+ 7
+ 7
8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}