$re = '/(?<=\d{2}\/\d{2}\/\d{2} )\d+(?:\.\d+)?/';
$str = 'SOMEDATA .test 01/45/12 2.50 THIS IS DATA
SOMEDATA .test 01/45/12 2500 THIS IS DATA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);