package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+\[[0-9]+\]`)
var str = `NetworkManager[1170]
NetworkManager [1170] `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}