const regex = /([^ ]*) ([^ ]*) ([^ ]*) (\[(.*)\]) (\"(.*)\") ([0-9]*) ([0-9]*) (\"(.*)\") (\"(.*))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^ ]*) ([^ ]*) ([^ ]*) (\\[(.*)\\]) (\\"(.*)\\") ([0-9]*) ([0-9]*) (\\"(.*)\\") (\\"(.*))', '')
const str = `70.39.184.135 - - [10/Dec/2014:19:20:59 +0530] "GET /wp-content/themes/wplms/js/bootstrap.min.js?ver=3.8.5 HTTP/1.1" 200 29074 "http://etlhive.com/redhat-linux-training-in-pune/" "UCWEB/2.0 (Symbian; U; S60 V3; en-US; NokiaC5-00.2) U2/1.0.0 UCBrowser/9.2.0.336 U2/1.0.0 Mobile"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}