# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<Username>[-\w\.]+)(?:\s+\W*at\W*\s+|\s*[^\@\s]*?@[^\@\s]*?\s*)(?P<Domain>([\w\-]+)(?:(?:\.|\s+\W*?dot\W*?\s+)([\w\-]+))+?(?:(?:\.|\s+\W*?dot\W*?\s+)([\w\-]+))??$)"
test_str = ("Parse email, also distorted ones, and convert them back to the real ones.\n"
"Inspirated by dislick's work: https://regex101.com/r/wB7xJ7/1\n\n"
"frenci98@gmail.com\n"
"st11389@copernico.bo.it\n"
"gigilafontana .at. gmail [dot] com\n"
"d98.copernico@gmail.com\n"
"domenico-tosello at dotcom-sas dot com\n"
"my.e-M4il [at] w3-spAce.org\n"
"email@sub-sub.sub dot domain dot info\n"
"email@foo dot foo dot foo dot foo")
subst = "\\1@\\3.\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.