#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s){{\*(\w+)}}(.+?){{/\w+}}"
Local $sString = "<table>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <th>Trainee</th>" & @CRLF & _
" <th>Status</th>" & @CRLF & _
" <th>Invited</th>" & @CRLF & _
" <th>Score</th>" & @CRLF & _
" <th>Action</th>" & @CRLF & _
" </tr>" & @CRLF & _
" {{*Trainees}}" & @CRLF & _
" <tr>" & @CRLF & _
" <td>{{display_name}}</td>" & @CRLF & _
" <td>{{status}}</td>" & @CRLF & _
" <td>{{invited_date}}</td>" & @CRLF & _
" <td>{{percentage}}</td>" & @CRLF & _
" <td>Some action button</td>" & @CRLF & _
" </tr>" & @CRLF & _
" {{/Trainees}}" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")