import re
regex = re.compile(r"https:\/\/www\.chytryhonza\.cz\/srovnavac-zivotniho-pojisteni\?v=.+", flags=re.MULTILINE)
test_str = ("https://www.chytryhonza.cz/hypotecni-kalkulacka?v=iTBDcj1Zi0eb4mSEPe3k3CNWhpqvaZmAyRTmCq%2Be1j085RJkWNTwLmXX8mRWLjvUDUxgpyVpx0VS0q08qi%2FTIvRBMeiXW4w9fK%2F8cQg4wXlsDubtLGXAdytQCNC2LTfF\n"
"https://www.chytryhonza.cz/hypotecni-kalkulacka?v=\n"
"https://www.chytryhonza.cz/srovnavac\n"
"https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=dd\n"
"https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=1qC3j5r%2BHim0K68IAcodRMrYv6ikx0NneJC39H2oOdl2H8QZ5DL9glGwRtkQSV%2BhVT0c%2B95YLTSmA4BDugvpUQkWIDUmTmv4rcg1t78EMid9jhDOoHh%2BXxRZAxYBGKkB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")