import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A[A-Za-z]+(?:\\(-?[1-9][0-9]*\\))?(?:\\.[A-Za-z]+(?:\\(-?[1-9][0-9]*\\))?)*\\z";
final String string = "m(2).s(-1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}