$re = '/(?<=\/\/)(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(:[\d]{1,5})?(?=\/)/m';
$str = 'http://172.12.10.253:8/test/live
http://172.12.10.253:809009090/test/live
http://172.12.10:8090/test/live';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);