# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"construit dans les ann[eé]es (\d{2,4})"
test_str = ("[DATE DE CONSTRCUTION]\n\n"
"R1 = date de constuction \\W (\\d{4}[-/]\\d{4}|((\\w{3,12})\\s)?\\d{4}|(\\d{1,2}(\\s?er)?)? \\w{3,10} \\d{4}|\\d{2}/\\d{2}/\\d{2,4}|[ST]\\d{1,4} \\d{4}|((fin|d[ée]but)\\s)?[1234](er|[eè]mes?) (semestre|trimestre)|courant \\w{3,10}(\\s\\d{4})?|\\w{3,10}/\\w{3,10} \\d{4}|((fin|d[ée]but)\\s)?(semestre|trimestre) \\d{1,4} \\d{4})\n\n"
"date de constuction : 2000-2001\n"
"date de constuction : 1999/2000\n"
"date de constuction : 01/01/2020 \n"
"date de constuction : 01/01/03 \n"
"date de constuction : 1er janvier 2020\n"
"date de constuction : 1 er janvier 2020\n"
"date de constuction : 31 décembre 1997\n"
"date de constuction : juin 2020\n"
"date de constuction : Juillet/Juillet 2021\n"
"date de constuction : courant Juin\n"
"date de constuction : courant Juin 2003\n"
"date de constuction : été 2021\n"
"date de constuction : semestre 2 2028\n"
"date de constuction : début semestre 2 2028\n"
"date de constuction : S1 2024\n"
"date de constuction : T3 2020\n"
"date de constuction : 2ème semestre\n"
"date de constuction : 1er semestre\n"
"date de constuction : fin 2ème semestre\n"
"date de constuction : début 2020\n"
"date de constuction : fin 2022)\n\n"
"[CONSTRUIT EN]\n\n"
"R2 = construite?(\\s\\w{2,4})? (\\d{4}[-/]\\d{4}|((\\w{3,12})\\s)?\\d{4}|(\\d{1,2}(\\s?er)?)? \\w{3,10} \\d{4}|\\d{2}/\\d{2}/\\d{2,4}|[ST]\\d{1,4} \\d{4}|((fin|d[ée]but)\\s)?[1234](er|[eè]mes?) (semestre|trimestre)|courant \\w{3,10}(\\s\\d{4})?|\\w{3,10}/\\w{3,10} \\d{4}|((fin|d[ée]but)\\s)?(semestre|trimestre) \\d{1,4} \\d{4})\n\n"
"construit en 1996\n"
"construit en 2006\n"
"construit en 2000-2001\n"
"construit en 1999/2000\n"
"construit le 01/01/2020 \n"
"construit le 1er janvier 2020\n"
"construit en Juin 2020 \n"
"construit en Juillet/Juillet 2021\n"
"construit courant Juin\n"
"construit à l'été 2021\n"
"construit au Semestre 2 2028, \n"
"construit au S1 2024\n"
"construit au T3 2020\n"
"construit au 2ème semestre\n"
"construit fin 2ème semestre\n"
"construit début 2020\n"
"construit fin 2022\n\n"
"R3 = construit dans les ann[eé]es (\\d{2,4})\n"
"construit dans les années 90 \n"
"construit dans les années 2000\n\n"
"construit au siècle dernier ??")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.