using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(.*?)""";
string input = @"""THREAD1"" daemon prio=10 tid=0x00007ff6a8007000 nid=0xd4b6 runnable [0x00007ff7f8aa0000]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}