#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\d+)(?:st|[nr]d|th)?-?(\d*)(?:st|[nr]d|th)?\s*Apr(?:il)?|Apr(?:il)?\s*(\d+)(?:st|[nr]d|th)?-?(\d*)(?:st|[nr]d|th)?"
Local $sString = "02 APR" & @CRLF & _
"" & @CRLF & _
"APR 02" & @CRLF & _
"" & @CRLF & _
"2 APR" & @CRLF & _
"" & @CRLF & _
"APR 2" & @CRLF & _
"" & @CRLF & _
"2nd APR" & @CRLF & _
"" & @CRLF & _
"APR 2nd" & @CRLF & _
"" & @CRLF & _
"2nd April" & @CRLF & _
"" & @CRLF & _
"April 2nd" & @CRLF & _
"" & @CRLF & _
"APR 12th" & @CRLF & _
"" & @CRLF & _
"April 12th" & @CRLF & _
"" & @CRLF & _
"12th April" & @CRLF & _
"" & @CRLF & _
"April 13-16" & @CRLF & _
"" & @CRLF & _
"13-16 April" & @CRLF & _
"" & @CRLF & _
"APR 13-16" & @CRLF & _
"" & @CRLF & _
"13-16 APR" & @CRLF & _
"" & @CRLF & _
"April 13th-16th" & @CRLF & _
"" & @CRLF & _
"13th-16th April" & @CRLF & _
"" & @CRLF & _
"APR 13th-16th" & @CRLF & _
"" & @CRLF & _
"13th-16th APR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")