import re
regex = re.compile(r"(\w+.\d+\s.\d.\d+.\d+) (\w+\s\w+\s\w+.\w+.) (\w+...\w+.\w+.\w+.\w+.\w+.)(\d+.)(\w+.\w+.\w+.)(\d+.\d+.\d+.\d+.)(.+)")
test_str = "Jun 30 08:37:38 dev10 drupal provd-va: http://prod-va.ctg.albany.edu|1435667858|page not found|85.17.180.245|http://prod-va.ctg.albany.edu/favicon.ico||0||favicon.ico"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")