re = /^\+61(?(?=1800)1800\d{6}|\d{9})$/m
str = '+611800123456
+61123456789
+61180012345
+6112345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end