re = /^((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$/m
str = '127.0.0.1
192.168.1.1
192.168.1.255
255.255.255.255
0.0.0.0
1.1.1.01
55.91.5.117
30.168.1.255.1
127.1
192.168.1.256
-1.2.3.4
3...3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end