import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+((-|\\.|_)\\w+)*\\w*@\\w+(-\\w)?(\\w*)?\\.\\w{2,3}(\\.\\w{2,3})?$";
final String string = "# invalid email\n"
+ "abc\n"
+ "abc.com\n\n"
+ "# valid email address\n"
+ "abc@mail.com\n"
+ "abc@mail.nz\n"
+ "abc@mail.co.nz\n"
+ "abc123@mail.com\n"
+ "abc.def@music.com\n\n"
+ "# invalid email prefix\n"
+ "abc-@mail.com\n"
+ "abc..def@mail.com\n"
+ ".abc@mail.com\n"
+ "abc#def@mail.com\n\n"
+ "# valid email prefix\n"
+ "abc-d@mail.com\n"
+ "abc.def@mail.com\n"
+ "abc@mail.com\n"
+ "abc_def@mail.com\n\n"
+ "# invalid domain suffix\n"
+ "abc.def@mail.c\n"
+ "abc.def@mail#archive.com\n"
+ "abc.def@mail\n"
+ "abc.def@mail..com\n\n"
+ "# valid domain suffix\n"
+ "abc.def@mail.cc\n"
+ "abc.def@mail-archive.com\n"
+ "abc.def@mail.org\n"
+ "abc.def@mail.com\n"
+ "fully-qualified-domain@example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}