$re = '/xtra-tester(\d){2}(?!.)/';
$str = 'xtra-tester123
xtra-tester123sad123
xtra-tester123
xtra-tester12
xtra-tester12s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);