package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^0-9]*)([0-9]+).*`)
var str = `This is a phrase 22ext`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}