$re = '/^<p><img src="https?:\/\/\S.+?<\/p>/';
$str = '<p><img src="https://testing.com" /><span class="test">testing</span><p>testing</p></p>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);