package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-z.\/-]+|(.)`)
var str = `ABCD123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}