$re = '/\[vc_column_text\](.*?)\[\/vc_column_text\]/s';
$str = 'Our good homies <a href="https://www.facebook.com/yungskeeter">DJ Skeet Skeet aka Yung Skeeter</a> & <a href="https://www.facebook.com/WaxMotif">Wax Motif</a> have teamed up to do a colossal 2-track EP and we\\\'re getting the exclusive sneak-premiere of the EP\\\'s diabolical techno b-side called "Hush Hush" before its released tomorrow on <a href="https://www.facebook.com/dimmakrecs">Dim Mak Records</a>!
[soundcloud url="http://api.sndcloud.com/tracks/104477594"]
<a href="https://www.facebook.com/WaxMotif">Wax Motif</a> have teamed up to do a colossal 2-track EP and we\\\'re getting the exclusive sneak-premiere of the EP\\\'s diabolical techno b-side called "Hush Hush" before its released tomorrow on <a href="https://www.facebook.com/dimmakrecs">Dim Mak Records</a>!
[vc_row_inner]
[vc_column_inner width="3/12"]
[gem_textbox content_background_color="#f0f3f2" centered="1" padding_top="25" padding_bottom="25" padding_left="0" padding_right="0"]<img class="alignnone size-medium wp-image-6608" src="https://shop.teor.events/wp-content/uploads/2020/09/Screenshot_2020-09-30-home-Business-300x223.png" alt="" width="300" height="223" />[/gem_textbox]
[/vc_column_inner]
[vc_column_inner width="5/12"]
[vc_column_text]
Vino Rosso Passito
Uve:100% Vernaccia NeraVigneti:Loc. Sogliano -ColleluceBottiglie prodotte: 2.500 unica edizione.. Tipo di terreno:ghiaioso-breccioso. Esposizione: sud-est a 500 m.s.l.m. Resa per ettaro: 5-7tonnellate. Acidità totale:5,40% . Estratto secco:38,80 ‰.Zuccheri residui:12g/l. Processo: raccolta e selezione a mano, appassimento delle uve in apposite cassette in legno per 2-3mesi, fermentazione in barriques per 18 mesi e affinamento in bottiglia per almeno 6 mesi.
<div class="wpb_text_column wpb_content_element ">
<div class="wpb_wrapper"></div>
</div>
[/vc_column_text]
[/vc_column_inner]
[vc_column_inner width="4/12"]
[gem_textbox content_background_color="" padding_top="10" padding_bottom="0" padding_right="0" padding_left="18" border_color="#cccccc" border_width="1"][gem_dropcap shape="circle" letter="1" color="#9b4ce4" border_color="#9b4ce4"]
[vc_empty_space height="3px"]
[vc_column_text]
AZIENDA AGRICOLA COLLELUCE
[/vc_column_text]
[gem_divider margin_top="20"][/gem_textbox][gem_divider margin_top="-25"][gem_textbox content_background_color="" padding_top="10" padding_bottom="0" padding_right="0" padding_left="18" border_color="#cccccc" border_width="1"][gem_dropcap shape="circle" letter="2" color="#4f67e1" border_color="#4f67e1"][vc_empty_space height="3px"][vc_column_text]
CONTRADA SOGLIANO SERRAPETRONA
[/vc_column_text][gem_divider margin_top="20"][/gem_textbox][gem_divider margin_top="-24"][gem_textbox content_background_color="" padding_top="10" padding_bottom="0" padding_right="0" padding_left="18" border_color="#cccccc" border_width="1"][gem_dropcap shape="circle" letter="3" color="#00bcd4" border_color="#00bcd4"][vc_empty_space height="3px"][vc_column_text]
62020 - (MC)
[/vc_column_text][gem_divider margin_top="20"][/gem_textbox][/vc_column_inner][/vc_row_inner]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);