import Foundation
let pattern = #".*\s(\d{11}|\d{5}\s\d{3}\s\d{3}|\d{5}\s\d{6}|\d{14}|\+\d{12}|\+\d{3}\s\d{3}\s\d{3}\s\d{3}|\d{4}\s\d{3}\s\d{3})\s.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fdsgf dsgfd ggfs s 07123452670 ar gs fgsdf gsdf
t hth rt hrth rth 07812 345 931 tr yrt rty
try erty tr ytr y 07412 123466 tr yert y
tery ert y 00447912345188 etry ert y
tery etr yrt yret +971557017442 ert yert yrety
et yetr yertytr ety ert y +971 557 856 832 etry rt ytr y
etr yerty etry erty 0414 934 993 erty etry etry
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)