$re = '/\h([A-Z ]+)[,\h]+([A-Z]{2})\h+(\d{5}(?:-d{4})?)$/m';
$str = '3333 10TH ST., N. #201, WEST PALM BEACH FL 34103
3333 10TH ST., N. #201, WEST PALM BEACH, FL 34103';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);