$re = '/(\d+.(?=<))/';
$str = '<add>te+103551</add>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);