re = /(\d+)(?!.*\d)/m
str = 'xtra-tester123
xtra-tester123sad123
xtra-tester123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end