Please enable JavaScript to use regex101
Regular
Expressions
101
Support Regex101
Social
Info
Regex Editor
Community Patterns
Account
Regex Quiz
Settings
Save & Share
Current Version:
1
Update Regex
ctrl+⇧+s
Save new Regex
ctrl+s
Add to Community Library
Flavor
PCRE2 (PHP)
ECMAScript (JavaScript)
Python
Golang
Java
.NET 7.0 (C#)
Rust
PCRE (Legacy)
Regex Flavor Guide
Function
Match
Substitution
List
Unit Tests (5)
Tools
Code Generator
Regex Debugger
Export Matches
Benchmark Regex
Sponsors
There are currently no sponsors.
Become a sponsor today!
Explanation
An explanation of your regex will be automatically generated as you type.
Quick Reference
Search reference
All Tokens
Common Tokens
General Tokens
Anchors
Meta Sequences
Quantifiers
Group Constructs
Character Classes
Flags/Modifiers
Substitution
A single character of: a, b or c
[abc]
A character except: a, b or c
[^abc]
A character in the range: a-z
[a-z]
A character not in the range: a-z
[^a-z]
A character in the range: a-z or A-Z
[a-zA-Z]
Any single character
.
Alternate - match either a or b
a|b
Any whitespace character
\s
Any non-whitespace character
\S
Any digit
\d
Any non-digit
\D
Any word character
\w
Any non-word character
\W
Non-capturing group
(?:...)
Capturing group
(...)
Zero or one of a
a?
Zero or more of a
a*
One or more of a
a+
Exactly 3 of a
a{3}
3 or more of a
a{3,}
Between 3 and 6 of a
a{3,6}
Start of string
^
End of string
$
A word boundary
\b
Non-word boundary
\B
Regular Expression
/
/
Unit Tests
Run tests
Add test