import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\n"
+ "(?:\n"
+ " (?:^from\\s+\n"
+ " ( # Base (from (base) import ...)\n"
+ " (?:[a-zA-Z_][a-zA-Z_0-9]* # Variable name\n"
+ " (?:\\.[a-zA-Z_][a-zA-Z_0-9]*)* # Attribute (.attr)\n"
+ " )\n"
+ " )\\s+import\\s+\n"
+ " )\n"
+ "|\n"
+ " (?:^import\\s|,)\\s*\n"
+ ")\n"
+ "( # Name of imported module (import (this))\n"
+ " (?:[a-zA-Z_][a-zA-Z_0-9]* # Variable name\n"
+ " (?:\\.[a-zA-Z_][a-zA-Z_0-9]*)* # Attribute (.attr)\n"
+ " )\n"
+ ")\n"
+ "(?:\n"
+ " \\s+as\\s+\n"
+ " ( # Variable module is imported into (import foo as bar)\n"
+ " (?:[a-zA-Z_][a-zA-Z_0-9]* # Variable name\n"
+ " (?:\\.[a-zA-Z_][a-zA-Z_0-9]*)* # Attribute (.attr)\n"
+ " )\n"
+ " )\n"
+ ")?\n"
+ "\\s*\n"
+ "(?=,|$) # Ensure there is another thing being imported or it is the end of string";
final String string = "import pandas, os, sys";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}