$re = '/^[a-zA-Z]{2,50}\s[a-zA-Z]{2,50}(-[a-zA-Z]{2,50})?$/';
$str = 'HJHFGJHG HGJHJ-JFHJHG';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);