#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*Summer.*"
Local $sString = "_id": ObjectId("001")," & @CRLF & _
" "searchkey": "Test Product Test Product T-shirt Half sleeves Adidas"" & @CRLF & _
"} " & @CRLF & _
"{" & @CRLF & _
""_id": ObjectId("123"), " & @CRLF & _
" "searchkey": "boy test Product Test Product T-shirt Half sleeves Nike"" & @CRLF & _
"} " & @CRLF & _
"{" & @CRLF & _
""_id": ObjectId("456"), " & @CRLF & _
" "searchkey": "girl test Product Summer Product T-shirt full sleeves Adidas"" & @CRLF & _
"} " & @CRLF & _
"{" & @CRLF & _
""_id": ObjectId("789"), " & @CRLF & _
" "searchkey": "any product any Product any Product T-shirt full sleeves Adidas"" & @CRLF & _
"} " & @CRLF & _
"{" & @CRLF & _
""_id": ObjectId("1010"), " & @CRLF & _
" "searchkey": "woodland Product woodland Product T-shirt Half sleeves woodland"" & @CRLF & _
"} " & @CRLF & _
"{" & @CRLF & _
""_id": ObjectId("1212"), " & @CRLF & _
"" & @CRLF & _
" "searchkey": "Summer Product Test Product T-shirt Half sleeves Adidas"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")