#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^begin.*(?:\n(?!begin|end$).*)*\b536916223\b.*(?:\n(?!begin|end$).*)*\nend$"
Local $sString = "begin active link" & @CRLF & _
" export-version : 11" & @CRLF & _
" actlink-order : 2" & @CRLF & _
" wk-conn-type : 1" & @CRLF & _
" schema-name : HelpDesk" & @CRLF & _
" actlink-mask : 1" & @CRLF & _
" actlink-control: 750000002" & @CRLF & _
" enable : 1" & @CRLF & _
" action {" & @CRLF & _
" set-field : 0\536916222\101\4\1\1\" & @CRLF & _
" }" & @CRLF & _
" errhandler-name: " & @CRLF & _
"end" & @CRLF & _
"begin active link" & @CRLF & _
" export-version : 11" & @CRLF & _
" actlink-order : 2" & @CRLF & _
" wk-conn-type : 1" & @CRLF & _
" schema-name : HelpDesk" & @CRLF & _
" actlink-mask : 1" & @CRLF & _
" actlink-control: 610000092" & @CRLF & _
" enable : 1" & @CRLF & _
" permission : 0" & @CRLF & _
" action {" & @CRLF & _
" id : 536916223" & @CRLF & _
" focus : 0" & @CRLF & _
" access-opt : 1" & @CRLF & _
" option : 0" & @CRLF & _
" }" & @CRLF & _
" action {" & @CRLF & _
" set-field : 0\536916222\101\4\1\1\" & @CRLF & _
" }" & @CRLF & _
" errhandler-opt : 0" & @CRLF & _
" errhandler-name: " & @CRLF & _
"end" & @CRLF & _
"begin active link" & @CRLF & _
" actlink-order : 12" & @CRLF & _
" wk-conn-type : 1" & @CRLF & _
" schema-name : HelpDesk" & @CRLF & _
" actlink-mask : 2064" & @CRLF & _
" enable : 1" & @CRLF & _
" permission : 0" & @CRLF & _
" action {" & @CRLF & _
" id : 536916223" & @CRLF & _
" focus : 0" & @CRLF & _
" access-opt : 1" & @CRLF & _
" option : 0" & @CRLF & _
" }" & @CRLF & _
" action {" & @CRLF & _
" set-field : 0\536916222\101\4\1\1\" & @CRLF & _
" }" & @CRLF & _
" errhandler-opt : 0" & @CRLF & _
" errhandler-name: " & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")